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Purpose and scope
The purpose of this guide is to help you successfully use the Composer for the 
4350 Mobile Fault Finder Series features and capabilities. This guide includes 
task-based instructions that describe how to install, configure, use, and trouble-
shoot the Composer for the 4350 Mobile Fault Finder Series. Additionally, this 
guide provides a description of Willtek’s warranty, services, and repair informa-
tion, including terms and conditions of the licensing agreement.

Assumptions
This guide is intended for novice and intermediate users who want to use the 
Composer for the 4350 Mobile Fault Finder Series effectively and efficiently. We 
are assuming that you have basic computer and mouse/track ball experience and 
are familiar with basic telecommunication concepts and terminology.

Related information
Use this guide in conjunction with the following information:

4350 Mobile Fault Finder: Getting Started Manual (ordering number M 295 543)

Technical assistance 
If you need assistance or have questions related to the use of this product, call 
one of Willtek’s technical assistance centers. You can also contact Willtek by 
e-mail at customer.support@willtek.com.

Conventions
This guide uses naming conventions and symbols, as described in the following 
tables.

Table 1 Technical assistance centers

Region Phone number Fax number

Europe, Middle East, 
Asia, Africa

+49 (0) 89 996 41 386
+49 (0) 89 996 41 227

+49 (0) 89 996 41 440

Americas +1 973 386 9696 +1 973 386 9191

China +86 21 5836 6669 +86 21 5835 5238
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Table 2 Typographical conventions

Description Example

User interface actions appear in this 
typeface.

On the Status bar, click Start.

Buttons or switches that you press 
on a unit appear in this TYPEFACE.

Press the ON switch.

Code and output messages appear 
in this typeface.

All results okay

Text you must type exactly as 
shown appears in this typeface.

Type: a:\set.exe in the dialog 
box.

Variables appear in this <typeface>. Type the new <hostname>.

Book references appear in this type-
face. 

Refer to Newton’s Telecom Dictio-
nary

A vertical bar | means “or”: only one 
option can appear in a single com-
mand.

platform [a|b|e]

Square brackets [ ] indicate an 
optional argument.

login [platform name]

Slanted brackets < > group required 
arguments.

<password>

Table 3 Keyboard and menu conventions 

Description Example

A plus sign + indicates simultaneous 
keystrokes.

Press Ctrl+s

A comma indicates consecutive key-
strokes.

Press Alt+f,s

A slanted bracket indicates choos-
ing a submenu from menu.

On the menu bar, click 
Start > Program Files.
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Table 4 Symbol conventions

This symbol represents a general hazard.

This symbol represents a risk of electrical shock.

NOTE

This symbol represents a note indicating related information or tip.
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Chapter 1 Overview

This chapter provides a general description of the Composer for the 4350 Mobile 
Fault Finder Series. 
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About the Composer for the 4350 Mobile Fault Finder Series
The Composer software

– allows quick and easy customization of 4350 test programs.

– creates loadable .csl files which contain the network and mobile lists 
(selectable in the 4350 test program), along with the corresponding network 
and mobile phone connection data.

– uses Wizards for customizing bay data.

– allows default values for all operational parameters to be customized for 
different networks and mobile phone types.

– is an external Windows®-based program.

– allows for external/remote setup of simulated networks / mobile phone loss 
data.

– transfers simulated network and loss data to the 4350 via floppy disks.

The 4350 Series Mobile Fault Finder

– tests mobile phones at the point-of-return using upgradeable programs to 
simulate various networks.

– runs sequence programs

– contains a pre-loaded set of simulated networks and mobile phone loss data

– provides no GUI for setting up sequence programs, simulated networks, or 
mobile phone loss data
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Chapter 2 Installation

This chapter describes how to install the Composer for the 4350 Mobile Fault 
Finder Series. The topics discussed in this chapter are as follows:

– “Software requirements” on page 4

– “Hardware requirements” on page 4

– “Installing the software” on page 4
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Software requirements
The Composer software can be installed from CD on a PC with either Windows  
2000 with Service Pack 2 or Windows XP as the operating system. Ensure to have 
sufficient administrator’s rights to install the software on the PC.

Hardware requirements
The Composer software can be executed on a PC. A floppy disk drive is required 
to transfer program scripts into the 4350 Series Mobile Fault Finder using floppy 
disks. 

Installing the software
Insert the Composer CD into the CD drive.

If the installation does not start automatically, call up install.bat from the CD by 
double-clicking on the file name in the Windows Explorer.
The Composer Setup program will start and guide you through the installation; 
follow the on-screen instructions.

When the Composer Setup is completed, the Composer Utility software will be 
installed. Unzip the files into the folder where you previously installed Composer.

Warning

Make sure that you install the Composer Utility into the same folder as Com-
poser itself, otherwise you will not be able to use the additional Utility func-
tions!
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Chapter 3 Getting Started

This chapter describes the functionality of the instrument. Topics discussed in 
this chapter are as follows:

– “Starting the Composer software” on page 6

– “System overview” on page 6

– “Operational overview” on page 9

– “System preferences” on page 11

– “Control channel programming” on page 12

– “Voice channel programming” on page 14

– “Network wizard” on page 15

– “Mobile connection wizard” on page 20

– “File librarian” on page 27

– “Viewing the output file” on page 29
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Starting the Composer software
If you installed the software in the Composer applications group, click on Start 
> Programs > Composer > Composer to call up the software.

System overview
The initial Composer screen consists of six sections: menu options, toolbar, work 
area, model number selection screen, control area, status area.

Menu Options

The File menu includes:  New CSL File, Open Existing CSL File, Save, Save As, View 
Current CSL File, and Exit commands.

The Bay Functions menu includes: Rename Bay, Go to Voice Channel, Go to 
Control Channel, and Apply commands.

The Wizards menu includes: Network, Mobile Connection and Hard Copy wizards.

The Preferences menu allows selection of Composer Preferences.

The Help menu allows access to the Help system, which includes context-sensi-
tive help and a tutorial.
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Toolbar Options The toolbar consists of:

Create a NEW file with default parameters
Starts a new, unnamed Composer Settings source code file.

Open an existing CSL file
Opens an existing Composer Settings source code file, loading its parameters 
into Composer.

Save current CSL file
Saves the current Composer Settings file. If the file has not been named, this 
reverts to Save As.

View the current CSL file
Opens a separate window to view the Composer Settings source file that 
Composer is creating.

Network Wizard
Opens  the Network wizard.

Mobile Connection Wizard
Opens the Mobile Connection wizard

Hard Copy Wizard
Opens the Hard Copy Printout Wizard

Work area The appearance of the work area varies with the selected function.
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Model number selection
screen

After selecting the model number, click Go to Programming to set up the 
control and voice channel, or go to the Preferences menu to select different 
settings.

Control area

Network Selection box

Select the current active network from the drop down list.

Rename Bay button

Rename the currently active network.

The bay name is displayed on the 4350 network selection screen.

The Status area

Composer provides a status bar, which contains program operation data.

Table 1 Model number and capabilities

Model # AMPS NAMPS CDMA TDMA PCS

4351 X X

4352 X X X

4353 X X X X

4354 X X X

4355 X X X X

Note

After selecting Go to Programming, select File > New CSL File.
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File Name panel file.

Model Type panel
Contains the 4350 model type selected.

Date panel
Contains the current time and date, updated in real time.

Operational overview
Composer uses Microsoft Windows operational interface functions.

Audience Composer users should be familiar with 4350 Series Mobile Fault Finder (4350) 
operation, and with cellular/ PCS standards and operation.

Refer to the 4350 Series Mobile Fault Finder user’s guide for information on 
operating and upgrading the 4350.

Purpose Composer generates a read-only customized Composer Settings file (.csl) which 
contains customized network and mobile phone data.

Menu operations Left-click the mouse to view menu/ sub-menu options.

Highlight and left-click again to select a menu or sub-menu option. 

Keyboard shortcuts, where available, are listed to the right of the menu/sub-
menu option. 

Types of command buttons Command Buttons: 

To select a command button, move the mouse cursor over it and left-click the 
mouse or press Tab to move; the focus rectangle from one command button to 
the next. 

No Note

If your mouse is configured for right-handed use, the left mouse button is the 
primary button and the right button is the secondary button.
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Press Shift+Tab to reverse the movement of the focus rectangle.

Button with Focus Rectangle: 

Button without Focus Rectangle: 

The command button with the focus rectangle is activated. To change any text 
value, enter it manually or press the  or  key, or press the space bar to 
select or deselect a check box.

Radio Button: 

Radio Buttons are used where only one choice can be selected. Selecting one 
choice will automatically de-select any others.

To select a radio button, either left-click the mouse on it or use the Tab key to 
move the focus rectangle on to the control, then press the  or  key.

Check Box: 

Check boxes are used where none, any or all choices can be selected.

Check boxes are also used to shift between two choices.

To check or uncheck a check box, either left-click the mouse on it or use Tab to 
move the focus rectangle over the control, then press the space bar.

Spinner Control: 

Left-click the mouse on either the top arrow or bottom arrow to automatically 
increment or decrement the number appearing in the attached box.

Number or text entry
boxes

Number Entry:  Text Entry:  

To manually change numbers, left-click the mouse on the text inside the box and 
type in the new number.

Number boxes accept only numeric entries. Alpha entries ("ABC") are not 
accepted.

To select the text box, left-click the mouse on the text inside the box and type 
in new text. 

Text boxes accept both alpha ("ABC") and numeric ("123") entries.

To select either type of box without using the mouse, press Tab until the infor-
mation in the desired box is highlighted. Type in the new data.
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Combination boxes Combination Box: 

Combination boxes are used where a large number of pre-selected choices 
(either text or numeric) are available. The Network Selection Drop Box is a 
combination box.

To use the combination box, left-click the mouse on the arrow  attached to 
the box. This displays a list of available choices. Left-click the mouse over the 
desired choice.

If the mouse is not available, press Tab until the box is highlighted, then use the 
 or  key to select the desired choice.

Drag-and-drop interface The Network Wizard and the Mobile Connection Wizard use the Microsoft® 
Windows drag-and-drop interface.

Drag-and-drop is an object-oriented GUI. Each Composer element becomes an 
object.

Dragging is accomplished by moving the mouse cursor over an object, then 
pressing and holding down the left mouse button. If the object is drag-able, a 
special cursor appears that can be moved around the screen while the left mouse 
button is held down.

Dropping is accomplished by moving the mouse cursor over a compatible object 
and releasing the mouse button. A compatible object will be highlighted when 
the mouse is moved over it.

The Wizards handle all functions necessary to move the data from one bay to 
another.

If a certain area is not available for dropping, the mouse cursor will change to a 
 symbol.

Attempting to drop an object on a non-compatible object, or dropping onto an 
unused area will simply cause the drop to be rejected.

Using the drag-and-drop function without a mouse can be accomplished 
through buttons, keyboard controls or menus. See Chapter 4 “Composer How-
Tos” for an explanation of a specific function.

System preferences
After selecting a model number, click , or select a 
different Preferences setting from the Main Menu.
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System preferences To set Composer preferences, select Preferences > Composer Preferences 
from the main menu.

Toolbar visibility

To view the toolbar/status bar, check the toolbar/status bar option.

To hide the toolbar/status bar uncheck the toolbar/status bar option.

General options

Add comments

  Check this box to add comments for each line of SCPI code.

Control channel programming
To program control channel parameters for each network:

1 Select a model number.

2 Left-click  to open the Control Channel screen.

CAUTION

Ensure that the correct 4350 model number is selected to allow loading of the 
desired .csl files.
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Setting default values To select the default values or reset all parameters to a default value, left-click 
.

Setting customized values To select customized values, click on the desired control for:

Analog: Select Type, Channel, SID and Band.

Digital: Select Type, Channel, SID, NID and Band.

Channel Use this to select the channel number assigned to the control 
channel.

SID Use this to set the value of the system ID.

NID Use this to set the value of the network ID.

Analog Pointer The analog channel directs the mobile phone to the selected 
digital control, to speed up acquisition time.

Note

Ensure that the SID is set to the correct value for your system.

Note

This is only available for CDMA.

Note

This is only available for TDMA cellular.

Note

The Analog Pointer is not customizable. This information is displayed only for 
notification to the user that this function is being used in the currently 
selected mode.
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Band Use this to select the control channel band: Cellular (800 MHz) 
or PCS (1900 MHz).

Apply Use  to save the control channel values.

If you attempt to leave this screen without saving the changes, you will be 
prompted to Save Changes?

Voice channel programming
To program the voice channel parameters for each type of mobile phone to be 
tested, select a model number and then left-click on . At the 
Control Channel screen, click on  to open the Voice Channel 
screen.

NOTE: When the Control Channel is selected as PCS, the Voice Channel will 
default to PCS, and appear like so:

Setting default values To select the default values or reset all parameters to default values, left-click 
.

Setting customized values Refer to “Operational overview” on page 9 for help on using Windows controls.

To select customized values, click on the desired control for:

Analog: Band, Channel, Chan. Type

Digital: Band, Channel, Chan. Type

Band Indicates the Voice Channel band: Cellular ( 800 MHz) or PCS 
(1900 MHz).
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Channel Use this to select the voice channel value.

Channel Type Indicates the channel type AMPS, NAMPS, CDMA, or TDMA.

Example: For CDMA Control Channels, select CDMA Voice 
Channels.
For analog Control Channels, select AMPS or 
NAMPS Voice Channels.

Return to control
channnel

Click  to return to the Control Channel area.

If the  button is disabled, left-click .

Apply Use  to save the Voice Channel values.

If you attempt to leave this screen without saving the changes, you will be 
prompted to Save Changes?

Network wizard
The Network Wizard is designed to organize and maintain a library of network 
setup data.

The 4350 supports the storage and selection of the operational parameters of up 
to ten (10) networks. Each network parameter file includes:

– Control channel data 
(SID, NID – if digital, Analog Pointer – if TDMA cellular, Band,Type)

– Voice channel information
(Band, Type)

The 4350 allows the user to select network parameter files from a stored network 
library. 

The Network Wizard allows the user to customize the loading, saving, and 
arranging of network information for use with the 4350.

Note

The selected voice channel band is the same as the selected control channel 
band.

Note

This may be set to any value within the range of channels available to this 
band and type. Ensure that the Voice Channel number is set to the correct 
value for your system.

Note

Voice Channel options are linked to Control Channel options.
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Managing network files The Network Wizard enables the management of network data files.

At the main menu, click  to open the Network Wizard.

Selecting the active
network

Management of network files begins with the selection of a network.

Left-click on one of the numbered control buttons (1-10), or use Tab to move 
the focus rectangle into the network box and press Enter to activate the 
network.

Naming or renaming the
network

A network must have a name before it can be written to the output file.

1 If the name is highlighted, type in a new name or double-click on the Name: 
box to bring up the Rename Settings Bay dialog box.

2 Type a new name into the dialog box.

Note

Operational parameters cannot be set from this screen.

Note

The current name appears in the Name: box.

Note

Network names are limited to twenty (20) characters. If you attempt to enter 
more than 20 characters, the name will be truncated to the first 20 charac-
ters.
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Moving network data Moving a network name from any bay number (1-10) to any other bay number, 
moves the source network data into the new bay and deletes the network data 
from the old bay.

Using a mouse:

1 Move the cursor over the name of the network to be moved.

2 Press and hold the left mouse button (the antenna symbol appears).

3 Drag the cursor to the new bay (the new bay is highlighted) .

4 Release the left mouse button.

Using menus:

1 Left-click a bay to select a source network.

2 From the Bay Functions menu, select Move Bay.

3 In the Move dialog box, select the From and To entries.

4 Click OK.

Using buttons:

Click on the Move button, or use Tab to move the focus rectangle onto the Move 
button, or select Alt-M.

In the Move To dialog box, select the new bay number.

Click OK.

Copying a network Copying a network name from any bay number (1-10) to any other bay number 
copies the source network data into the new bay. It does not delete the network 
data from the source bay.

Network data may be copied to any bay. The data is copied into the new bay. 
Either or both copies may be renamed.

Using a mouse:

1 Move the cursor over the name of the network to be copied.

2 Press and hold the left mouse button (the antenna symbol appears).

3 Drag the cursor to the Copy box. 

4 Release the left mouse button.

5 Press and hold the left mouse button over the Copy box (the antenna symbol 
appears).

6 Drag the cursor to the new bay (the new bay is highlighted). 

Note

The currently selected bay is assumed to be the bay to be moved.
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7 Release the left mouse button.

8 Make as many copies of the Copy location as needed.

Using menus:

1 Left-click a bay to select a source network.

2 From the Bay Functions menu, select Copy Bay.

3 In the Copy To dialog box, select the copy From and To entries.

4 Click OK.

Using buttons:

1 Click on the Copy button, or use Tab to move the focus rectangle onto the 
Copy button, or select Alt-C.

2 Select the Copy To bay number.

3 Click OK.

Deleting a network When customized network information is deleted, the network is set to default 
values.

Using a mouse:

1 Move the cursor over the network to be deleted.

2 Press and hold the left mouse button (the antenna symbol appears and 
changes to a  symbol as it is dragged away.)

3 Drag the cursor to the  icon. The antenna symbol re-appears and the 
trash can is outlined when the cursor is in the proper position.

4 Release the left mouse button.

5 Respond to the warning message that appears.

Using menus:

1 Left-click a bay to select a source network.

2 From the Bay Functions menu, select Delete Bay.

3 In the Delete dialog box, select the bay to delete the data from.

4 Click OK.

Note

The copied location will not be deleted.

Note

The currently selected bay is assumed to be the bay to be moved.

Caution

Once the information in a network is erased, it cannot be recovered.
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Using buttons:

1 Click on the Delete button, or use Tab to move the focus rectangle onto the 
Delete button, or select Alt-D.

2 Click OK.

Saving network data to
disk

Network data files are saved using the bay name and an .ssl extension.

Using a mouse:

1 Move the cursor over the network to be saved to disk.

2 Press and hold the left mouse button (the antenna symbol appears).

3 Drag the cursor to the  icon. The icon is outlined when the cursor is in 
the proper position.

4 Release the left mouse button.

Using menus:

1 Left-click a bay to select a source network.

2 From the Bay Functions menu, select Save Bay.

3 At the Save dialog box, select the bay number.

4 Click OK.

Using buttons:

1 Left-click a bay to select the source network.

2 Click on the Save button, or use Tab to move the focus rectangle onto the 
Save button, or select Alt-V.

3 At the Save As dialog box, select the file path and bay name.

4 Click OK.

Note

The highlighted bay is assumed to be the bay to be deleted.

Note

The bay is saved on the local hard drive under the name assigned in the Name: 
box. For example, if the bay is named "Bay 15", the resulting file will be "Bay 
15.ssl".

Note

The bay is saved on the local hard drive under the name assigned in the Name: 
box.
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Loading network data
from disk

Using a mouse:

1 At the Network Wizard screen, move the cursor over the open file icon 
.

2 Press and hold the left mouse button.

3 While holding the left mouse button, drag the cursor to the desired network 
location. The network location will be highlighted  when the 
cursor hovers over it.

4 Release the left mouse button.

5 From the Open dialog box, double-click on the desired .ssl file.

Using menus:

1 At the Network Wizard screen, select Bay Functions > Load Bay.

2 At the Load Into dialog box, select a bay number to load data into.

3 At the Open dialog box, double-click on the desired .ssl file.

Using buttons:

1 At the Network Wizard screen, click on a network bay.

2 Click on the Load button, or use Tab to move the focus rectangle onto the 
Load button, or select Alt-L.

3 At the Open dialog box, double-click on the desired .ssl file.

Mobile connection wizard
The Mobile Connection Wizard is designed to organize and maintain a library of 
insertion loss factors (organized by make and model of the mobile phone).

The 4350 allows the user to enter or load, store, re-arrange and recall up to 
twenty (20) insertion loss factor sets for cellular (800 MHz) and PCS (1900 MHz) 
transmit and receive bands, and to set pass/fail limits.

Managing the insertion
loss files

The Mobile Connection Wizard enables the management of insertion loss data 
files.

Note

Only network data files with an .ssl extension can be loaded from a disk.

Note

Insertion loss is affected by many factors: cable length, connector character-
istics, isolation box characteristics, and mobile phone physical and electrical 
characteristics.
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Insertion loss factors and test limits are set at this screen.

Click  to open the Mobile Connection Wizard.

Selecting the active
mobile connection bay

Management of insertion loss files begins with the selection of a mobile connec-
tion bay.

Click on one of the numbered control buttons (1-20) with the mouse, or use Tab 
to move the focus rectangle into the box and press Enter to activate the bay.

Naming or renaming the
mobile connection bay

The current bay name appears in the Name: box.

If the name is highlighted, type in a new name.

To rename a bay, double-click on the Name: box to bring up the Rename Mobile 
Connection Bay dialog box. Type a new name into the dialog box.

Adding comments to a
mobile connection bay

Comments, such as the name and model of the phone, i.e.: "XYZ Model 42", 
may be added to the bay description.

Comments will be displayed on the 4350.

Left click in the Comment box, and type in a new comment or edit the current 
comment.

Note

Bay names are limited to twenty (20) characters. If more than 20 characters 
are entered, the name will be truncated to the first  20 characters.



Chapter 3 Getting Started
Mobile connection wizard

22 Composer for the 4350 Mobile Fault Finder Series Version 2.20

Insertion loss Insertion loss indicates signal strength loss between the 4350 Series Mobile Fault 
Finder's RF output jack and the mobile phone antenna, and can cause inaccurate 
test measurements or test failure.

Insertion loss is related to phone frequency and to whether the phone is trans-
mitting or receiving. The 4350 adjusts for insertion loss of up to 30dB in both 
cellular (800 MHz) and PCS (1900 MHz) bands, in both transmit and receive 
modes.

To minimize insertion loss, connect the mobile phone directly to the 4350's RF 
output jack using a cable which is specially designed for the make and model of 
phone being tested. If the cable connector does not match the RF output 
connector on the 4350, use an adapter (which introduces additional insertion 
loss).

The antenna coupler provides no direct connection between the mobile phone 
and the 4350. Instead, the phone is placed in a special cradle, which is perma-
nently fixed over a radiation plate. The signals from the 4350 are air coupled to 
the mobile phone through the radiation plate.

Both the direct connection and antenna coupler methods introduce some inser-
tion loss into the test process, but each can be compensated for by programming 
the loss factors into the 4350 using Composer.

Characterizing insertion
loss

Characterization is the process of adjusting for insertion loss factors. Composer 
provides default characterizations based on specific combinations of mobile 
phones (make and model) and the connection method (direct or coupled).

Enter customized loss factors into the appropriate boxes in the Mobile Connec-
tion Wizard in 0.1 dB increments up to 30 dB.

Note

Comments are limited to thirty (30) characters. If you attempt to enter more 
than 30 characters, the comment will be truncated to the first 30 characters.
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Setting test limits Test limits determine the pass/fail limits used by 4350 the test program.

Coupler Wide test limits allow for the most variation between the programmed 
loss factors and those actually present in the system of all the test limit settings. 
This setting may cause marginal units to pass.

Use the Coupler Normal test limits when testing a known and characterized 
make and model of phone in an RF isolation box.

Use the Direct Normal setting only if a direct connection is used. Using Direct 
Normal for coupled connections may result in test failures on healthy phones.

Moving mobile connection
bays

Moving a mobile connection bay from any location to any other location results 
in the source data being moved into the new bay and deleted from the source 
bay.

Using a mouse:

1 Move the cursor over the bay to be moved.

2 Press and hold the left mouse button (the mobile symbol appears).

3 Drag the cursor to the new bay (the new bay is highlighted). 

4 Release the left mouse button.

Using menus:

1 Left-click a bay to select a source bay.

2 From the Bay Functions menu, select Move Bay.

3 In the Move dialog box, select the From and To bay numbers. Click OK.

4 Click OK.

Note

The direct connection method is more accurate than the coupled method.

Note

Include a generic phone type to be used for testing phones that have not been 
characterized. Select a test limit setting that is similar to the phone being 
tested.
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Using buttons:

1 Click on insert the Move button, or use Tab to move the focus rectangle 
onto the Move button, or select Alt-M.

2 At the Move To dialog box, select the new bay number.

3 Click OK.

Copying a mobile
connection bay

Copying a mobile coupler bay name from any bay number (1-20) copies the 
source bay information into the new bay number.

Data is copied into the new bay and two (2) copies of the source bay data are 
kept in the Librarian. Either or both copies may be renamed and their parameters 
edited.

Using a mouse:

1 Move the cursor over the name of the bay to be copied.

2 Press and hold the left mouse button (the mobile symbol appears).

3 Drag the cursor to the COPY: box. 

4 Release the left mouse button.

5 Press and hold the left mouse button over the COPY: box (the mobile symbol 
appears).

6 Drag the cursor to the new bay (the new bay is highlighted). 

7 Release the left mouse button.

8 Make as many copies of the COPY: location as needed.

Using menus:

1 Left-click a bay to select a source bay.

2 From the Bay Functions menu, select Copy Bay.

3 At the Copy dialog box, select the From and To bay numbers.

4 Click OK.

Using buttons:

Note

The currently selected bay is assumed to be the bay to be moved.

Note

It does not delete the bay information from the source bay.

Note

The currently selected bay is assumed to be the bay to be copied.
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1 Click on the Copy button, or use Tab to move the focus rectangle onto the 
Copy button, or select Alt-C.

2 Select the Copy To bay number.

3 Click OK.

Deleting a mobile
connection bay

When customized bay information is deleted, the bay is set to default values.

Using a mouse:

1 Move the cursor over the bay to be deleted.

2 Press and hold the left mouse button (the mobile symbol appears and 
changes to a  symbol as it is dragged away).

3 Drag the cursor to the  icon. The mobile symbol re-appears and the 
trash can is outlined when the cursor is in the proper position.

4 Release the left mouse button.

5 Respond to the warning message that appears.

Using menus:

1 Left-click a bay to select a source bay.

2 From the Bay Functions menu, select Delete Bay.

3 In the Delete dialog box, select the bay number.

4 Click OK.

Using buttons:

1 Click on the Delete button, or use Tab to move the focus rectangle onto the 
Delete button, or select Alt-D.

2 Click OK.

Saving mobile connection
bay data to disk

Bay data files are saved using the bay name and an .msl extension.

Using a mouse:

1 Move the cursor over the bay to be saved.

2 Press and hold the left mouse button ( the antenna symbol appears and 
changes to a  symbol as it is dragged away).

Warning

Once the information in a bay is erased, it cannot be recovered.

Note

The highlighted bay is assumed to be the bay to be deleted.
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3 Drag the cursor to the  icon. The disk icon is outlined when the cursor is 
in the proper position.

4 Release the left mouse button.

Using menus:

1 Left-click a bay to select a source bay.

2 From the Bay Functions menu, select Save Bay.

3 In the Save dialog box, select the bay number to be saved.

4 Click OK.

Using buttons:

1 Click on the Save button, or use Tab to move the focus rectangle onto the 
Save button, or select Alt-V.

2 At the Save As dialog box, select a file path and name the bay.

3 Click Save.

Loading mobile connection
bay data from disk

Bay data files loaded from a disk have a .msl extension.

Using a mouse:

1 Move the cursor over the  icon.

2 Press and hold the left mouse button.

3 Drag the cursor to the desired bay location. The bay location will be high-
lighted  when the cursor is in the proper position.

4 Release the left mouse button.

5 At the Open dialog box, select the desired .msl file.

6 Click Open.

Using menus:

1 Left-click on a bay to select it.

2 From Bay Functions menu, select Load Bay.

3 At the Load Into dialog box, selected the bay number to have the .msl loaded 
into it.

4 Click OK.

5 At the Open dialog box, select the desired .msl file.

6 Click Open.

Note

The currently selected bay is assumed to be the bay to be deleted.
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Using buttons:

1 Left-click on a bay to select it.

2 Click on the Load button, or use Tab to move the focus rectangle onto the 
Load button, or select Alt-L.

3 At the Open dialog box, selected the desired .msl file.

4 Click Open.

File librarian
Bay data entered at each of the Wizards can be viewed using the Librarian.

The Librarian enables access to only the files (on either local or network drives) 
which are compatible with the current application.

Selected files can be loaded into Composer at the Librarian.

The main screen

The Librarian dialog box disables the Wizards. Press Done to return to the 
Wizards.

Note

The currently selected bay is assumed to be the bay to be deleted.
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Bay contents list

The Bay Contents window lists the bays created in either Wizard.

Drive and directory list

Select the file path for reading files by using the drive pull down menu  to 
view all drives attached to this computer (floppy disks, hard disks, CD-ROMs, and 
mapped network drives).

The Directory and Available Files windows are updated as the file path is selected.

Available files list

Note

Bay data cannot be changed from this screen.

Note

The Bay Contents window may not be completely filled if the Librarian is 
accesssed from the Network Wizard as the Network Wizard accepts only 10 
bays, but the Bay Contents window can display more than 10 entries.
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The Available Files window lists all files in the selected directory which meet the 
setup criteria (file extension).

If no files in the selected directory match the setup criteria, the Available Files 
window is empty. 

Available Entries, Entries
Used

 

These windows display the number of available bays and the number of bays 
being used.

As bays are setup with the corresponding Wizard, the Bay Contents window 
listing changes.

Remove To delete an entry in the Bay Contents list, highlight it and click >>Remove.

Remove All To delete all entries in the Bay Contents list, click >>Remove All.

Add To add an entry from the Available Files list to the Bay Contents list, highlight it 
and click <<Add.

Add All To add all entries from the Available Files List to the Bay Contents list, click 
<<Add All.

The preferred method of adding files is to use the Add button rather than the Add 
All button.

Done Click Done to transfer the Bay Contents list into bays managed by the Wizard.

Viewing the output file
Select the  icon to view the Composer Settings(.csl) file.

Note

The entry is not removed from the Available Files window.

Note

There may be more files in the Available Files list than available bays. Add All 
adds files to the Bay Contents list in the order in which they appear in the 
Available Files list, and when the Bay Contents list is full, subsequent files are 
ignored.
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This screen displays the output (.CSL) file generated by Composer. Use this screen 
to:

– verify that all parameters are set as desired,

– print a hard copy of the output file for archiving purposes,

– cut and paste text from this screen into other documents.

Resize the Sequence window by moving the cursor over the border of the window 
until the cursor changes to a double-headed arrow . Left-click and drag 
the border until the window is the desired size.

Fonts Select the font for this screen (and the printer) from the Preferences > Font 
menu.

Printing Select File > Print to print from this screen.

The default font is Fixedsys 10 pt. Regular.

Editing

Select text using the mouse 1 Move the cursor  in front of the selected text, and left-click the mouse 
button.

2 To select text, click and drag the cursor across the text to highlight it.

Caution

Any edits made at this screen are not made to the .csl file.

Note

Composer locates and uses the default printer for the computer.

Caution

Edits to this screen are not reflected in the .csl file. 
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3 Release the left mouse button.

Select text using the keyboard 1 Use the  keys to move the cursor in front of the selected text.

2 Press and hold the Shift key.

3 Use  to highlight the selected text.

4 Release the Shift key.

Select all text using the mouse 1 From the Edit menu, select Select All.

Select all text using the
keyboard

1 Press Ctrl-A.

Copy text using the mouse 1 Highlight selection.

2 From the Edit menu, select Copy.

Copy text using the keyboard 1 Highlight selection.

2 Press Ctrl-C.

Hardcopy wizard
For a hard copy of the data bay print out, select Wizards > Hard Copy Wizard, 
or click  at the main screen.

The Bay Data Print Out window displays Network Storage and Mobile Connection 
Bay data.
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The display window Resize the Bay Data Print Out window for easier viewing.

To resize, position the cursor over one of the edge borders or corners until the 
cursor changes to double arrows , click and drag to adjust the size of the 
window.

The control channel and voice channel data appears on the display window. Use 
the scroll bars to see the entire display.

Network check boxes Select which network bay data to print by clicking the cursor on the check 
box . Bays associated with unchecked boxes  will not appear in the 
printout.

Disabled boxes indicate bays that are not configured, and are not printed.

Coupler loss check boxes Select which coupler loss information to print by  clicking the cursor on the 
check box. Bays associated with unchecked boxes  will not appear in the 
printout.

Disabled boxes indicate bays that are not configured, and are not printed.

File menu Click Refresh or select Files > Refresh to update the display after making 
changes to the bay data.

Print Click Print or select Files > Print.

Preferences menu Select the font from the Preferences > Font menu.

Select the default font from the Preferences > Default Font menu. The default 
font is Fixedsys 10pt Regular.

Help menu This box displays copyright notices and software version number.

Click OK to return to the hard copy printout window.
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Chapter 4 Composer How-Tos

This chapter provides task-based instructions for using the Composer for the 
4350 Mobile Fault Finder Series features. Topics discussed in this chapter are as 
follows:

– “How do I save the Composer Settings (.csl) file?” on page 34

– “How do I rename an existing .csl file?” on page 35

– “How do I load a previously saved .csl file?” on page 35

– “How do I clear Composer and start a new .csl file?” on page 35

– “How do I view the .csl file?” on page 35

– “How do I name or rename a network or mobile bay?” on page 35

– “How do I select a new or different network?” on page 36

– “How do I tell Composer what hardware features I have?” on page 36

– “How do I open the Network Wizard?” on page 37

– “How do I open the Mobile Connection Wizard?” on page 37

– “How do I print the .csl file?” on page 37

– “How do I set the font for the Sequence window?” on page 37

– “How do I set the default font for the Sequence window?” on page 37

– “How do I get more help?” on page 37

– “How do I move data from one bay to another?” on page 37

– “How do I add bay files from disk?” on page 39

– “How do I delete a bay?” on page 40

– “How do I get a printout of the bay data?” on page 41

– “How do I set the font for the hard copy printout?” on page 41

– “How do I set the default font for the hard copy printout?” on page 41
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How do I save the Composer Settings (.csl) file?
The Composer output file has a .csl (Combined Setup Load) extension. This file is 
copied to the 4350's boot disk.

To save the .csl file:

From the main screen, click on  or select File > Save.

If the file has previously been saved, Composer will attempt to re-save it under 
the existing name. This results in a request from Composer that you confirm the 
overwrite.

A new, previously unsaved file needs to be named in one of two formats:

DOS 8.3 format A 1-8 character filename and 3 character extension. (composer.csl)

DOS 8.3 format is required if the file is written to a floppy diskette.

Composer examines the drive letter selected at the Save As dialog box. The DOS 
8.3 format is strictly enforced for drives A or B. (These drives are assigned as 
floppy disk drives in a Windows environment.)

Composer assumes that the files may be transferred to a 4350, which supports 
only DOS 8.3 file names.

When naming the file, Composer automatically adds the .csl file extension.

Windows long file name The valid length is in the range from 1 to 256 characters.

Long File Name format may be used if the file is being saved to a local hard drive.

Considerations For drives other than A or B, use either DOS 8.3 or Windows Long File Name 
formats.

Once a file is saved, its name is displayed in the Status Area.

To rename a previously saved file, select File > Save As from the main menu.

Note

In order for the file to be loaded into the 4350, the file must be named com-
poser.csl. To archive a file, any file name is acceptable, providing that the file 
is renamed to composer.csl before it is transferred to the 4350 disk.

Note

A warning appears if you attempt to save with a file name other than com-
poser.csl.
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How do I rename an existing .csl file?
To rename a .csl file, select File > Save As from the main menu, and save the 
file under a new name. 

How do I load a previously saved .csl file?
A previously saved .csl file can be reloaded into and modified in Composer.

To re-load .csl file:

From the main screen, click  or select File > Open Existing CSL File.

Once the file is loaded, its name will be displayed in the Status Area.

How do I clear Composer and start a new .csl file?
Composer is automatically cleared when first loaded. 

To clear Composer during use:

From the main menu, click  or select File > New CSL File.

How do I view the .csl file?
At the main screen, click  or select File > View Current CSL File. 

This opens the Sequence window.

What appears in the Sequence window depends on several factors:

– Networks must be named before they are saved. Unnamed networks will not 
appear in the .csl file.

– No comments will appear in the file if Add Comments is not checked.

How do I name or rename a network or mobile bay?

Rename a Network Bay from the main screen:

Note

If only the header is displayed, ensure that at least one network is named.

Note

An unnamed bay will not be written to the .csl file.
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1 From the main menu, select Bay Functions>Rename Bay or use Tab to 
move the focus rectangle onto the Rename Network button, and press 
Enter.

2 Name or rename the bay.

3 Click OK.

From the Network Wizard or Mobile Connection Wizard:

1 Click the mouse cursor inside the Name area or use Tab to move the focus 
rectangle into the Name area.

2 Type the desired name into the network name area.

How do I select a new or different network?
At the main screen:

1 Click on  in the Network Selection drop list.

2 Select the desired network or use Tab to move the focus rectangle into the 
Network Selection Drop List.

3 Use  or  to select the desired network number.

At the Network Wizard:

Click the mouse cursor anywhere within the Name: area for the desired network 
or click on the network number button or use Tab to move the focus rectangle 
onto the desired network number button and press Enter.

How do I tell Composer what hardware features I have?
The 4350's hardware features are coded into the model number:

– Model 4351 -- AMPS and NAMPS

– Model 4352 -- AMPS, NAMPS, and CMDA

– Model 4353 -- AMPS, NAMPS, CMDA, and PCS

– Model 4354 -- AMPS, NAMPS, and TMDA 

– Model 4355 -- AMPS, NAMPS, TMDA, and PCS 

Select the model number of the 4350 before selecting .

Note

Bay names are limited to twenty (20) characters. Names longer than 20 char-
acters will be rejected.



Chapter 4 Composer How-Tos
How do I open the Network Wizard?

Composer for the 4350 Mobile Fault Finder Series Version 2.20 37

How do I open the Network Wizard?
At the main screen, click on  or select Wizards > Network Wizard.

How do I open the Mobile Connection Wizard?
At the main screen, click on  or select Wizards > Mobile Connection 
Wizard.

How do I print the .csl file?
1 At the main menu, select File > View Current CSL File. 

2 At the Sequence window, select File > Print.

How do I set the font for the Sequence window?
From the Sequence window, select Preferences > Font.

How do I set the default font for the Sequence window?
From the Sequence window, select Preferences > Default Font.

The default font is Fixedsys 10 pt. Regular.

How do I get more help?
Press F1 for context-sensitive help for the screen you're using.

How do I move data from one bay to another?

Note

Close the Network Wizard to return to the main screen.

Note

Close the Mobile Connection Wizard to return to the main screen.

Caution

Moving data from one bay to another deletes the data in the source bay.
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Select either the Network Wizard  or the Mobile Connection Wizard .

Using buttons 1 Click on the Move button, or type Alt-M.

2 At the Move To dialog box fill in bay number.

3 Click OK, or type Alt-O. 

Using menus 1 Left-click on the network to be moved to select it.

2 At the Network Wizard, select Bay Functions > Move Bay.

3 At the Move dialog box, fill in the From and To entries.

4 Click OK, or type Alt-O. 

Using Drag and Drop 1 Move the mouse cursor over the source bay.

2 Press and hold the left mouse button.

3 While holding the left mouse button, move the cursor over the destination 
bay. (The bay is highlighted when the mouse is over a valid position.)

4 Release the left mouse button. (The name of the destination bay should be 
updated, and the name of the source bay should be cleared.)

5 Repeat Steps 3 and 4 as needed to make as many copies of the source bay as 
required.

How do I copy data from one bay to another?
Copying data from one bay to another does not delete the data in the old bay.

Select either the Network Wizard  or the Mobile Connection Wizard .

Using buttons 1 Click on the Copy button, or type Alt-C.

2 At the Copy To dialog box, fill in the bay number.

3 Click OK, or type Alt-O.

Using menus 1 Select the source bay by clicking on its selection button or in its name area.

2 From the Network Wizard, select Bay Functions > Copy Bay.

3 At the Copy dialog box, fill in the From and To entries.

Note

If you attempt to move data into a network that is already named, you will be 
asked to confirm the move.
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4 Click OK, or type Alt-O.

Using Drag and Drop 1 Move the mouse cursor over the source bay.

2 Press and hold the left mouse button.

3 While holding the left mouse button, move the cursor over the destination 
bay. (The destination bay is highlighted when the mouse is over a valid posi-
tion.)

4 Release the left mouse button. (The name of the destination bay should be 
updated while the name of the source bay is retained.)

5 Repeat steps 3 and 4 as needed to make as many copies of the source bay as 
required.

How do I add bay files from disk?
Select either the Network Wizard  or the Mobile Connection Wizard .

Adding Single Files

Using buttons 1 Left-click on the destination bay to select it.

2 Click the Load button, or type Ctrl-L.

3 At the Open dialog box, select the file (.ssl/.msl) to be loaded.

4 Click Open.

Using menus 1 At the Bay Functions menu, select Load Bay.

2 At the Load Into dialog box, fill in the bay number.

3 Click OK or type Alt-O.

Using Drag and Drop 1 At the Wizard menu, move the cursor over the  icon.

2 Press and hold the left mouse button.

3 While holding the left mouse button, drag the cursor to the destination bay. 
(The bay is highlighted  selected.)

4 Release the mouse button.

5 At the Open dialog box, select the file (.ssl/.msl) to be loaded.

6 Click Open.

Note

 If you attempt to move data into a network that is already named, you will be 
asked to confirm the move.
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Using the Librarian 1 At the Wizard screen, click Librarian>>.

2 At the Librarian screen, use the mouse to select the desired file from the 
Drive List and Directory List.

3 Click <<Add.

4 Click Done.

Adding Multiple Files

1 At the Wizard screen, click Librarian>>.

2 At the Librarian screen, use the mouse to select the desired files from the 
Drive List and Directory List. (The File List accepts multiple entries.)

3 Press and hold Ctrl. Drag the mouse over any number of consecutive entries.

4 Click <<Add.

5 Click Done.

ALL files from the Available Files list can be added to the Bay List by clicking 
<<Add All.

How do I delete a bay?
Select either the Network Wizard  or the Mobile Connection Wizard .

Using buttons 1 Left-click to select the bay to be deleted.

2 Click the DELETE button, or type Alt-T.

3 Respond to the warning that appears.

Using menus 1 From the Wizard screen, select Bay Functions > Delete Bay.

2 At the Delete dialog box, enter the bay number to be deleted.

3 Click the OK button.

Using Drag and Drop 1 Left-click to select the bay to be deleted.

2 Move the mouse cursor over the selected bay.

3 Press and hold the left mouse button.

4 While holding the left mouse button, drag the cursor to the  icon. (The 
Trash Can will be outlined when the cursor is in the proper position.)

5 Release the mouse button.

Note

Adding multiple files at one time can be done only from The Librarian.
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6 Respond to the warning that appears.

How do I get a printout of the bay data?
1 From the Wizard's main screen, select Wizards > Hard Copy Wizard or 

click .

2 At the Bay Data Printout screen, select which bays to print out by selecting 
the corresponding Network and Mobile check boxes.

3 Select File > Print or click Print.

How do I set the font for the hard copy printout?
1 From the Wizard's main screen, select Wizards > Hard Copy Wizard or 

click .

2 At the Bay Data Printout window, select Preferences > Font.

3 Select the font and style.

How do I set the default font for the hard copy printout?
1 The Network Information Printout Window font is selected from the CSL List 

Window Menu.

2 At the Wizard main screen, select Wizards > Hard Copy Wizard or 

click .

3 At the Bay Data Printout window, select Preferences > Default Font. The 
default font is Fixedsys 10 pt. Regular.
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Chapter 5 Using the Composer Utility Software

This chapter describes how to use the Composer Utility. The topics discussed in 
this chapter are as follows:

– “Overview” on page 44

– “Accessing the Composer Utility features” on page 44

– “4351, 4352, and 4353 utility features” on page 45

– “4354 and 4355 utility features” on page 48

– “4351, 4352, 4353, 4354 and 4355 common utility features” on page 52
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Overview
The Composer CDMA and TDMA Utility software retains the Composer features. 
These features allow the user to create, store, and change Composer files that 
contain Mobile and Network Bay configuration data for the complete line of 
Mobile Fault Finder products. New features allow the user to create, store and 
change additional Mobile Fault Finder Files. The new features are:

– Korean PCS Band
Composer Version  2.2Q adds the Korean PCS Band selection option when 
working with the 4353.

– Test Selection
This feature allows the user to select the tests that will be performed by the 
Mobile Fault Finder.

– Test Limit Editing
This feature allows the user to set the pass/fail test limits for all tests 
performed by the Mobile Fault Finder.

– Header File Creation
This feature allows the user to create and load Header files. These files 
contain information that is included in the Mobile Fault Finder test report. 

– Print Method Selection
This feature allows the user to select whether the Mobile Fault Finder will 
print results or not. It will also allow the user to select the print method if 
results are to be printed. 

Accessing the Composer Utility features
All of the new features are accessed through the check mark button on the tool 
bar, or through Wizards > Tests, Limits and Header Wizards as shown below.
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During installation, two sets of folders will be created that contain all of the files 
necessary to perform an “Upgrade Test” on a Mobile Fault Finder.

4351, 4352, and 4353 utility features

Select Tests menu The MAIN.mpg file must be opened before selecting any tests or editing any test 
limits. MAIN.mpg is located in the 4351_52_53Utility\UtilityAlterable folder that 
was created when the WinZip self-extracting (ComposerUtility.exe) file was run 
during installation. The default test will appear as shown below after MAIN.mpg 
is opened. Click the X box or choose Tests > Exit Select Tests to close Select 
Tests. The main Composer menu will appear.

Test Configuration and Test
Description

Information entered in the Test Configuration and Test Description text boxes 
will appear in the Test Configuration portion of the Upgrade and Configuration 
menu when loaded onto the Mobile Fault Finder. Use these text boxes for config-
uration control of the test programs you create.

Save Results You must check the Save Results check box if the Mobile Fault Finder should 
print results to the screen, a printer, or a floppy disk. The Manual Method allows 
the Mobile Fault Finder operator to select the print method (screen, printer, or 
disk) from the Mobile Fault Finder screen. The Automatic Method can be used to 
eliminate Mobile Fault Finder operator selection for the printing of results. If the 
Automatic Method is used, select the desired device (screen, printer or disk). If 
disk is selected as the print device, select how result files are saved to the floppy 
disk if the same file already exists on the disk (i.e. the same phone was tested a 
second time). The existing file can be overwritten or appended, or the save to disk 
can be cancelled.

Warning

Do not open or alter any files contained in these folders. The Mobile Fault 
Finder will not be able to load these files if altered outside of the Composer 
Utility software.
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Mobile Fault Finder operators should be informed when automatic printing of 
result files is implemented. They will need to make sure a printer is ready, or a 
floppy disk inserted before they begin any tests.

Print Header Check the Print Header check box if header information should be included in 
printed results. Any header file that has been loaded onto the Mobile Fault Finder 
using Upgrade Composer will be printed to a printer or a disk. Header information 
will not be printed if a header file has not been loaded onto the Mobile Fault 
Finder.

Selecting tests Selectable tests are divided into five separate groups. Tests will be run when their 
associated check box is checked. Uncheck all check boxes within a test group to 
eliminate that group. Click on the All Tests button to check, or No Tests to 
uncheck all of the test check boxes. The Mobile Fault Finder automatically 
detects the mobile’s capabilities, and only runs tests appropriate for the current 
mobile under test.

As an example, NAMPS Tests will only be performed on mobiles that support 
NAMPS, even if NAMPS tests are selected.

CDMA Tests

Tests in this test group will be run on the band selected in the Mobile Fault Finder 
Network selection. 

CDMA Tests (2nd Band)

Tests in this test group will be run on the opposite band selected in the Mobile 
Fault Finder Network selection. Tests in this test group are only run on dual band 
phones. 

If the Network selected on the Mobile Fault Finder is a CDMA PCS band Network, 
Tests selected under CDMA Tests will be run in the PCS band, and tests selected 
under CDMA Tests (2nd Band) will be run in the Cellular band, when testing Dual 
Band phones.

If the Network selected on the Mobile Fault Finder is a CDMA Cellular band 
Network, CDMA Tests will be run in the Cellular band, and CDMA Tests (2nd 
Band) will be run in the PCS band.

AMPS Tests

Tests in this test group will be run on mobiles that support AMPS. This can 
include Tri Mode, Dual Mode or AMPS only mobiles.

NAMPS Tests

Tests in this test group will be run on mobiles that support NAMPS.

General Tests

Sound Check: This is the CDMA Voice Echo check. It will only be performed on 
one band, whichever is first, when testing Dual band mobiles.
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Keypad Test: This is the Mobile Keypad test. This test will only be performed on 
the Network selected on the Mobile Fault Finder. The keypad is only tested once 
per mobile.

Test Limits menu The Test Limits menu is accessed through the Stop Light icon on the Select Tests 
tool bar, or through Wizards > Limits Wizard. The Test Limits menu is shown 
below. To close this screen click the X box or select Limits > Exit Limits. The 
Select Tests menu will appear.

Test Limits The test limits used during a test are dependent upon the RF connection to the 
Mobile. There are three types of connections. Two of these are through the 
Antenna Coupler, and the other is through a direct RF connection. The test limit 
type used during a test is selected when a phone selection is made on the Mobile 
Fault Finder. Make sure you select the correct Test Limits type before you begin 
editing. 

If you are unsure of the correct Test Limits type open the Composer.csl file with 
Composer, enter the Mobile Connection Wizard, and select the appropriate 
Mobile Connection Bay. The Test Limits type will be shown in the Test Limits box.

If a printout of a Mobile Fault Finder test report is available you can directly 
compare the limits to determine the correct Test Limits type.

The measurement units used in the Test Limits menu are the same units reported 
by the Mobile Fault Finder. This allows a direct comparison between the Test 
Limits menu and a printed report.

CDMA Limits The CDMA Limits box contains all of the test limits associated with CDMA tests 
currently available on the Mobile Fault Finder in both the PCS and Cellular bands.
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Max RF Power

Make sure you select the proper frequency band (PCS or Cell), and the proper 
Power Class before editing Max RF Power limits. The mobile’s abilities and Power 
Class are printed at the top of the Mobile Fault Finder test reports.

AMPS and NAMPS Limits The AMPS and NAMPS Limits box contains all of the limits associated with AMPS 
and NAMPS tests currently available on the Mobile Fault Finder. Analog Pow level 
2 – 7 limits are common to both AMPS and NAMPS tests. 

SAT Frequency

The Mobile Fault Finder reports the actual SAT Frequency (not the SAT Frequency 
error). The Test Limits menu uses SAT Frequency error. The changes made to these 
limits will affect all three SAT Frequency tests (SAT Frequency at 5970, 6000, and 
6030). All other AMPS and NAMPS limits appear as they do on the Mobile Fault 
Finder test report.

Base Power Level The user can alter the Mobile Fault Finder’s Base Power output level for three 
tests:

– MAX RF Power
This is the Base power output during the CDMA Max RF Power test in both 
the PCS and Cellular bands.

– FER Sensitivity
This is the Base power output during the CDMA FER Sensitivity test in both 
the PCS and Cellular bands.

– AMPS/NAMPS RX Sensitivity
This is the Base power output during the RX Sensitivity test. The same level 
is used for both AMPS and NAMPS.

4354 and 4355 utility features

Select Tests menu The MAIN.mpg file must be opened before selecting any tests or editing any test 
limits. MAIN.mpg is located in the 4354_55Utility\UtilityAlterable folder that 
was created when the WinZip self-extracting (ComposerUtility.exe) file was run 
during installation. The default test will appear as shown below after MAIN.mpg 
is opened. Click the X box or choose Tests > Exit Select Tests to close Select 
Tests. The main Composer menu will appear.
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Test Configuration and Test
Description

Information entered in the Test Configuration and Test Description text boxes 
will appear in the Test Configuration portion of the Upgrade and Configuration 
menu when loaded onto the Mobile Fault Finder. Use these text boxes for config-
uration control of the test programs you create.

Save Results You must check the Save Results check box if the Mobile Fault Finder should 
print results to the screen, a printer, or a floppy disk. The Manual Method allows 
the Mobile Fault Finder operator to select the print method (screen, printer, or 
disk) from the Mobile Fault Finder menu. The Automatic Method can be used to 
eliminate Mobile Fault Finder operator selection for the printing of results. If the 
Automatic Method is used, select the desired device (screen, printer or disk). If 
disk is selected as the print device, select how result files are saved to the floppy 
disk if the same file already exists on the disk (i.e. the same phone was tested a 
second time). The existing file can be overwritten or appended, or the save to disk 
can be cancelled.

Mobile Fault Finder operators should be informed when automatic printing of 
result files is implemented. They will need to make sure a printer is ready, or a 
floppy disk inserted before they begin any tests.
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Print Header Check the Print Header check box if header information should be included in 
printed results. Any header file that has been loaded onto the Mobile Fault Finder 
using Upgrade Composer will be printed to a printer or a disk. Header information 
will not be printed if a header file has not been loaded onto the Mobile Fault 
Finder.

Selecting tests Selectable tests are divided into four separate groups. Tests will be run when 
their associated check box is checked. Uncheck all check boxes within a test 
group to eliminate that group. Click on the All Tests button to check, or No Tests 
to uncheck all of the test check boxes. The Mobile Fault Finder automatically 
detects the mobile’s capabilities, and only runs tests appropriate for the current 
mobile under test.

As an example, NAMPS Tests will only be performed on mobiles that support 
NAMPS, even if NAMPS tests are selected.

TDMA Tests

Tests in this test group will be run on TDMA capable mobiles on the band selected 
in the Mobile Fault Finder Network selection. The tests in this test group will be 
run on both the PCS and Cellular bands if Tri-Mode Test is selected on the Mobile 
Fault Finder.

AMPS Tests

Tests in this tests group will be run on mobiles that support AMPS. These tests 
are performed independent of the Network selection made on the Mobile Fault 
Finder. If a TDMA Network is selected, TDMA and then AMPS tests will be 
performed. If a NAMPS Network is selected, NAMPS and then AMPS tests will be 
performed. If an AMPS Network is selected only AMPS tests will be performed.

NAMPS Tests

Tests in this test group will be run only if the Network selection made on the 
Mobile Fault Finder uses an NAMPS traffic channel. 

General Tests

Sound Check: This is the TDMA Voice Echo check. It will only be performed on 
one band when Tri-Mode Test is selected on the Mobile Fault Finder.

Keypad Test: This is the Mobile Keypad test. This test will only be performed on 
the Network selected on the Mobile Fault Finder. The keypad test is only tested 
once per mobile.

Test Limits menu The Test Limits menu is accessed through the Stop Light icon on the Select Tests 
tool bar, or through Wizards > Limits Wizard. The Test Limits menu is shown 
below. To close this menu click the X box or select Limits > Exit Limits. The 
Select Tests menu will appear.
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Test Limits The test limits used during a test are dependent upon the RF connection to the 
Mobile. There are three types of connections. Two of these are through the 
Antenna Coupler, and the other is through a direct RF connection. The test limit 
type used during a test is selected when a phone selection is made on the Mobile 
Fault Finder. Make sure you select the correct Test Limits type before you begin 
editing. 

If you are unsure of the correct Test Limits type open the Composer.csl file with 
Composer, enter the Mobile Connection Wizard, and select the appropriate 
Mobile Connection Bay. The Test Limits type will be shown in the Test Limits box.

If a printout of a Mobile Fault Finder test report is available you can directly 
compare the limits to determine the correct Test Limits type.

The measurement units used in the Test Limits menu are the same units reported 
by the Mobile Fault Finder. This allows a direct comparison between the Test 
Limits menu and a printed report.

TDMA Limits

The TDMA Limits box contains all of the test limits associated with the TDMA 
tests currently available on the Mobile Fault Finder. These limits apply to both 
the PCS and Cellular band.
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Transmitter Power (analog and digital)

The Transmitter Power test limits are common to TDMA, AMPS, and NAMPS tests. 
They are also common to TDMA tests run in the PCS or Cellular bands. Power 
Levels 7 through 10 are tested only if a direct connection to the Mobile is used, 
even if the associated check boxes are checked.

AMPS and NAMPS Limits

The AMPS and NAMPS Limits box contains all of the limits associated with  
AMPS and NAMPS tests currently available on the Mobile Fault Finder excluding 
Transmitter Power. 

SAT Frequency: The Mobile Fault Finder reports the actual SAT Frequency (not the 
SAT Frequency error). The Test Limits menu uses SAT Frequency error. The changes 
made to these limits will affect all three SAT Frequency tests (SAT Frequency at 
5970, 6000, and 6030). All other AMPS and NAMPS limits appear as they do on 
the Mobile Fault Finder test report.

Base Power Level

The user can alter the Mobile Fault Finder Base Power output during each of the 
Receiver Sensitivity tests.

4351, 4352, 4353, 4354 and 4355 common utility features

Header Wizard The Header Wizard allows the user to customize the Mobile Fault Finder test 
report. The Header Wizard is accessed through the hand-writing icon on the 
Select Tests tool bar, or through Wizard > Header Wizard. The Header Wizard 
menu is shown below. To close this screen click the X box or select File > Exit 
Header. The Select Tests menu will appear.
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Your Company Information Type information into any of these fields that you wish to appear in the header. 
If you do not want a field to appear, simply leave it blank. Check the Tested By 
check box if you would like to include a line in the header where the Mobile Fault 
Finder operator can write their name.

Your Customer’s Information Lines will appear in the header where the Mobile Fault Finder operator can fill in 
any desired customer information. Check the items you would like to include in 
the header and leave the rest unchecked.

Mobile Information Lines will appear in the header where the Mobile Fault Finder operator can enter 
the mobile’s point of purchase, purchase date, and warranty information. Check 
the items you would like to include and leave the rest unchecked.

View Header The user can view the header, as it will appear in the test report before loading 
it onto a Mobile Fault Finder. To view a header, click the Binoculars icon on the 
Header Wizard tool bar, or select File > View Header File. An example header 
file is shown below:
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Do not try to edit the header in the Header Viewer menu. Any changes made here 
are not saved. Close the Header Viewer and make changes in the Header Wizard 
menu.

Saving utility files When changes are made to any of the selected tests, test limits, or both, the 
changes affect all of the files contained in the UtilityAlterable folder. It is recom-
mended that you create a new folder when you save any changes. Three files will 
appear in the new folder.

Creating an upgrade test
disk

Start with a blank formatted floppy disk. Copy all of the files from the Utility-
Common folder onto the floppy. Next copy the three files from the folder you 
created (or the UtilityAlterable folder) onto the floppy disk. Any further changes 
only require you to replace the three altered files on the Upgrade Test disk.

Loading header files Header files are loaded onto the Mobile Fault Finder along with the Composer.csl 
file. Check the Load *.hdr File check box under General Options in the Composer 
Preferences menu if a header file should be loaded. You will be asked to locate 
the header file to be loaded when you save the Composer.csl file. Locate and click 
on the desired header file. Be sure to copy the same header file to the Composer 
disk when you create an Upgrade Composer disk. If the header file is missing the 
Mobile Fault Finder will display an error message during the upgrade.
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Appendix A End-User License Agreement

This appendix describes the conditions for using the software.
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All copyrights in and to the software product are owned by Willtek Communica-
tions or its licensors. The software is protected by copyright laws and interna-
tional copyright treaties, as well as other intellectual property laws and treaties.

This end-user license agreement grants you the right to use the software 
contained in this product subject to the following restrictions. You may not:

(i) use the software and/or any copy of the software in different computers 
concurrently, unless the software is an update that has been downloaded 
from the Internet at www.willtek.com;

(ii) copy the software, except for archive purposes consistent with your stan-
dard archive procedures;

(iii) transfer the software to a third party apart from the entire product;

(iv) modify, decompile, disassemble, reverse engineer or otherwise attempt 
to derive the source code of the software;

(v) export the software in contravention of applicable export laws and regu-
lations of the country of purchase;

(vi) use the software other than in connection with operation of the product.

The licensor's suppliers do not make or pass on to end users or any other third 
party, any express, implied or statutory warranty or representation on behalf of 
such suppliers, including but not limited to the implied warranties of nonin-
fringement, title, merchantability or fitness for a particular purpose.

Willtek Communications shall not be held liable for any damages suffered or 
incurred by you or any other third party (including, but not limited to, general, 
special, consequential or incidental damages including damages for loss of busi-
ness profits, business interruption, loss of business information and the like), 
arising out of or in connection with the delivery, use or performance of the soft-
ware.
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